Anyleaf PH Probe Dependency Installation Issue

Mycodo has been awesome so far, but I am having an issue installing dependencies for my Anyleaf PH probe.

I think the issue is that I don’t have the correct version of python to install scipy. Any help with this would be much appreciated!

[2022-05-24 19:45:35]
[2022-05-24 19:45:35] #### Installing/updating scipy==1.8.0 (pip-pypi)
[2022-05-24 19:45:36] Looking in indexes: Simple index, piwheels - Simple index
[2022-05-24 19:45:38] ERROR: Ignored the following versions that require a different python version: 1.8.0 Requires-Python >=3.8,<3.11; 1.8.0rc1 Requires-Python >=3.8,<3.11; 1.8.0rc2 Requires-Python >=3.8,<3.11; 1.8.0rc3 Requires-Python >=3.8,<3.11; 1.8.0rc4 Requires-Python >=3.8,<3.11; 1.8.1 Requires-Python >=3.8,<3.11
[2022-05-24 19:45:38] ERROR: Could not find a version that satisfies the requirement scipy==1.8.0 (from versions: 0.8.0, 0.9.0, 0.10.0, 0.10.1, 0.11.0, 0.12.0, 0.12.1, 0.13.0, 0.13.1, 0.13.2, 0.13.3, 0.14.0, 0.14.1, 0.15.0, 0.15.1, 0.16.0, 0.16.1, 0.17.0, 0.17.1, 0.18.0, 0.18.1, 0.19.0, 0.19.1, 1.0.0b1, 1.0.0rc1, 1.0.0rc2, 1.0.0, 1.0.1, 1.1.0rc1, 1.1.0, 1.2.0rc1, 1.2.0rc2, 1.2.0, 1.2.1, 1.2.2, 1.2.3, 1.3.0rc1, 1.3.0rc2, 1.3.0, 1.3.1, 1.3.2, 1.3.3, 1.4.0rc1, 1.4.0rc2, 1.4.0, 1.4.1, 1.5.0rc1, 1.5.0rc2, 1.5.0, 1.5.1, 1.5.2, 1.5.3, 1.5.4, 1.6.0rc1, 1.6.0rc2, 1.6.0, 1.6.1, 1.6.2, 1.6.3, 1.7.0rc1, 1.7.0rc2, 1.7.0, 1.7.1, 1.7.2, 1.7.3)
[2022-05-24 19:45:38] ERROR: No matching distribution found for scipy==1.8.0

[2022-05-24 19:45:38] End install of scipy

Yes, your python version is too old. Either update Python or install the latest version of your Linux distribution, which should have Python >= 3.8.

Hi Kyle I have a similar problem trying to install an Anyleaf PH probe, but went through the process of installing python 3.8 and ensuring it is set for default. I still get an error “could not build wheel for numpy which is required to installl pyprojects.toml- based projects” I can add the input device due to dependency requirement not met.

1 Like

Are you using a recent and updated version of Raspberry Pi OS? If so, you should be using a compatible Python version. If your OS is an old version or you installed it a long time ago, it may have an old Python version. Installing the latest OS fresh on a new SD card can often alleviate issues with an old OS and old software versions that may linger.

Hi Kyle I have now done a complete reset on the os re-flashed Debian Buster 22-04-04 onto new SD card up dated. Re installed mycodo. I get the same error “could not build wheel for numpy which is required to install pyprojects.toml- based projects” when trying to install Any leaf PH probe.