Atlas Scientific EC Returning Zero for all Measurements

Hey crew!

I’ve been slowly chipping away at a hydroponics project with Mycodo. I ordered an Atlas Scientific EC kit (this one) maybe a year ago now. My wife had a child and I’ve had to put this on the backburner until now, but pretty much all I did at the time was change it over to I2C mode and wire it up according to the official guide, set it up as a input and calibrate it. But for some reason it would only return zero for all the measurements. And that’s where I’m picking up from now.

I figured I’d go through Atlas’ Rasperry Pi example code to see if I could get something more barebones working.

I can confirm that the probe is visible as an i2c device:

$ sudo i2cdetect -y 1
     0  1  2  3  4  5  6  7  8  9  a  b  c  d  e  f
00:          -- -- -- -- -- -- -- -- -- -- -- -- --
10: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
20: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
30: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
40: -- -- -- -- -- -- -- -- 48 -- -- -- -- -- -- --
50: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
60: -- -- -- -- 64 -- -- -- -- -- -- -- -- -- -- --
70: -- -- -- -- -- -- -- --

But if I run the example i2c code:

$ python3
Traceback (most recent call last):
  File "", line 147, in <module>
  File "", line 60, in main
    device_list = get_devices()
  File "", line 30, in get_devices
    moduletype = response.split(",")[1]
IndexError: list index out of range

The list of devices returns empty?
I can alter the i2c address within Mycodo though, calibration and settings seem to work fine, but alll meaurement return as zero? If I set the wrong i2c address they return with NO DATA. So it seems some connection is occuring. Any thoughts?

Help would be much appreciated!

I see 2 addresses on your I2C bus tree. Have you disconnected all devices except for the EC board to ensure none of the other devices are the cause of the issue?

Yes! Sorry, I should have explained. 0x64 is the Atlas EC probe, 0x48 is an Anyleaf pH probe. Thanks for that suggestion, Kyle. Looks like that was what was holding up Atlas’ sample code, so it looks like the connection is fine then. Unfortunately I get similar ouput:

>> Enter command: Poll EC100
-------press ctrl-c to stop the polling
Success EC 100 : 0.00,0,0.00
-------press ctrl-c to stop the polling
Success EC 100 : 0.00,0,0.00
-------press ctrl-c to stop the polling
Success EC 100 : 0.00,0,0.00
-------press ctrl-c to stop the polling
^CContinuous polling stopped

I’ve noticed I get those zero measurements if run the EZO circuit without the probe. Possibly the connection to the probe is to blame? Is there any way I can test the probe with a multimeter?

You can’t measure without a probe connected.

Sorry, my point was more that if I get a zero reading with no probe and that reading doesn’t change at all with the probe connected, maybe there’s something wrong with the connection to the probe.

I’m not really sure where to go from here if the device is connecting fine but it’s not reading properly. Are there any situations where this might happen that’s not a hardware issue?

Is the probe in water?

Yep! Sure is. I’ve tried different amounts of salt in water as well as some of the kits calibration fluid but still reading is zero.

Sounds like something you might want to contact Atlas Scientific about. If measurements aren’t being acquired with their example code, it may be a hardware defect.

Yeah rats. I’ve sent them an email. I’ll keep this thread updated. Thanks for your help.

I ran into exactly the same situation. I suspect you have a bad EC probe. I purchased the very same kit from Atlas Scientific, sat on it for several months, then tried to install it only to find it would not calibrate or register anything but zeroes. Atlas Scientific confirmed it was a dead probe but would not replace it since it was outside of the 30 day return period. I had to buy another EC probe from them in the end. I went with their “shorty” model as it was a little cheaper and I didnt need the extra cable length in my setup.
Live and learn I guess, good luck!