Can't create new admin user

I’m getting started with a Mycodo set up and had the basic web GUI working. Unfortunately, I forgot my password and followed the reset instructions discussed elsewhere on the forum to delete my DB etc. and start again.

As expected, this took me to the create admin user page. When I tried to create an account, it kept reloading the same page.

Assuming something was on my Pi that was interfering, I completely wiped the Pi and started again. I installed Mycodo afresh. Went to create admin and…the same thing is happening!

Any ideas? Thanks :0)

1 Like

There is a “forgot password” link on the login page to reset your password. Do not rely on old forum posts, as they often are not current and can do more harm to your system. Deleting a database is a very serious move and can cause significant issues, and you should not do this unless specifically instructed by a dev to do so.

As for creating an Admin user, you should make sure your user name and password are of sufficient length and do not contain any non-standard characters.