Dashboard Widget Layout Keeps Resetting

After the update to 8.12.5 the dashboard layout on both of our systems keep resetting back to small blocks in random order.

After taking the time to redo the dashboard, locking and saving; then when the dashboard is selected from the menu Data / (dashboard name), the layout is reset back to an unreadable layout.

Saving of the layout occurs immediately after a drag/drop or resize, so there is no manual saving.
Have you tried deleting your cache? Have you tried a different browser?

Also, upgrade to the latest release and see if the issue persists.

I tried the cache and multiple browsers. Did the update and it seems to have fixed the problem. I’m resetting all the widgets now.

I also started the upgrade on our second system while the first was updating. The second one said it was complete after a few seconds, which I knew was a problem. It won’t allow me to login now. I’ll be searching the forum for how to recover that system. Luckily I did a backup yesterday.

1 Like

Can you attach the upgrade log?

mycodoupgrade.log (1.0 MB)

The log states the upgrade took 121 seconds. That’s about what my Pi 4s take to upgrade. There aren’t any issues logged, so it should work fine.

I agree after looking through the log myself. What was strange was the new upgrade complete page displayed after a couple of seconds. Since the upgrade actually took a 121 seconds to really complete, the system was unresponsive. It just happened to occur right when I was replying to your other message. Sorry for the false alarm.

Unfortunately the dashboard reset again this morning. I noticed it when opening on an iPad using chrome. Opened the site using safari on my mac and it had in fact reset. As a test I opened our second setup on the iPad and it displayed properly. Guessing it wasn’t the iPad. Attached is an image of the reset today. It looks almost identical to the prior incident.

This system has a smaller second dashboard. It is still okay.

As a test, I’m going to make a new dashboard (it’s a pain as it takes an hour to build).

I’m not sure what to say. There aren’t any other reports of this issue, and it appears to be something related to browser caching. None of my systems (of which there are many) have had this issue, either. Unless it can be replicable with a series of steps that always induces it, I’m not sure what can be done.

Actually i’ve been having this issue too when switching between phone and desktop client, ive resorted to specific dashboards

1 Like

Can you provide specific, detailed steps to replicate the issue?

simply opening the client and accessing a dashboard made on a desktop client, will reset its size on the phone client.

I could not replicate the issue. I opened PC firefox desktop and made a dashboard with several widgets, opened Android firefox mobile to the same desktop, then refreshed firefox desktop and it displayed properly

I have the same issue. Occurred after updating to the latest Mycodo build.

Can provide a specific set of steps to replicate the issue?

Is this still an issue with the latest version (released yesterday)? If so, could someone please provide detailed steps to reproduce, including software and version numbers?

Hi Kyle,
Yes, this issue is still happening - until I read this thread I was assuming it was something I was doing incorrectly but I was coming to the conclusion that after viewing a dashboard on my mobile (Android, Chrome) when I next try view the dashboard on either my laptop (Win10, Chrome) or PC (Mageia Linux, Firefox) the dashboard has been compressed as in the attached picture below.

This was a fresh install of Buster-Full yesterday with Mycodo and mosquitto installed, nothing else.
I will double check I can reproduce the results and be right back :slight_smile:

1 Like

…and, as is typical in these situations… I now cannot repeat it! :flushed:

PS. I’m a newbie to Mycodo having only recently being introduced to it by a friend seeing me struggle with my own incarnation of data collection software - your’s is brilliant!! I am amazed by it. Thank you so much. :slight_smile:

1 Like

Hello everyone, I also had the problem and I was no longer shown anything on the digital displays. but I found the solution for you guys. try times with your browser. with (Ctrl & + -) That fixed the problem for me, have a nice day and have fun with your Raspberry
And thank you Kyle for making all of this possible for us

1 Like