ERROR while Installing Dependencies for VL53L1X

Hi Kyle
When I try to add VL53L1X as an input, it asks to install dependencies. After installation of dependencies log shows following errors
[2023-01-20 07:16:07] Dependency installation beginning. Installing: VL53L1X

[2023-01-20 07:16:07]
[2023-01-20 07:16:07] #### Installing/updating vl53l1x==1.0.4 (pip-pypi)
[2023-01-20 07:16:09] Looking in indexes: Simple index, piwheels - Simple index
[2023-01-20 07:16:10] ERROR: Could not find a version that satisfies the requirement vl53l1x==1.0.4 (from versions: 0.0.4, 0.0.5)
[2023-01-20 07:16:10] ERROR: No matching distribution found for vl53l1x==1.0.4

[2023-01-20 07:16:10] End install of VL53L1X

[2023-01-20 07:16:10]
[2023-01-20 07:16:10] #### Setting permissions

[2023-01-20 07:16:12] #### Dependencies installed. Restarting frontend and backend…

[2023-01-20 07:16:17] #### Dependency install complete.

It is unable to install dependencies and add input

There’s a typo in the Input module. You can make the following change and restart and it should work.

Hi Kyle,
I tried to do the changes in .py file but I get error that permission denied. So I created a new input for VL53L1X with changes mentioned by you and susccessfully imported the module. Now dependencies got installed but now all input sensors readings show 0, display SSD1306, shows message ERROR on all lines. So I deactivated the input and tried to delete it but now that is also not working. I hope this is reversible and I dont have to reintall Mycodo. LOL

Please see the pics attached.

You should not import a module that already exists. Delete that imported module and perform an upgrade.

Ok… I will do that. Thank you very much.

1 Like