Help restoring mycodo

Hey Kyle, hope you’re doing well this friday :slight_smile:
I’ve gotten a new micro sd & i have mycodo installed on a new raspi os flash,
and im wondering how i import my zipped up back up file to the restore page, i downloaded the backup on my pc and used a flash drive to move them onto my raspberry pi.
attempted to use sudo cp ( /var/Mycodo-backups, and it works, i think, after initially not giving my permission but when i go to my restore page i see no backup available

You can both export and import a setting archive file from the More → Export Import page.

I didnt export it from there, i downloaded a back up from the restore page, when i try to upload the file to the two options on that page they reject it


Just restart with your old card and perform an export.

1 Like

So i did this and everything is set up except for my dashboards, that now will not load any data and i cant make any new one dashboards either

Did you install the same Mycodo version as the one that the export file was created with? You can delete all dashboards from the Diagnostics Settings page. Additionally, make sure you clear cache otherwise you may be using old CSS/JS from a previous Mycodo install if it’s the same IP/domain.

ya the one i exported from my old card is up to date with my new one, where would i find the cache?

It’s browser specific, so you would have to look up the docs for your browser.

Hey so i’ve tried, and ive even tried using browsers that have not logged into the system before like chromium on the pi (its usually headless logging in from elsewhere) to no avail…

Then it’s probably not a caching issue and you should try the other option I mentioned.

ive deleted and attempted to remake the dashboards, deleting them from the settings page, when i try to make a new dashboard i can configure a widget, the outlined box will show but nothing inside it just a gear box in the upper right and the icon to move it around

Any errors in your browser’s page inspection console?

No errors there, so no idea what the issue is.

okay redownloading and starting from scratch