How to access the web interface from another computer?

I can access and change settings just fine at from the Pi web browser (WiFi). But I cant from my desktop which is connected via cable.


how can I set it up to access through the internet?

Can you elaborate?

If your desktop and the Pi are on the same network, you will need to find the IP address assigned to the Pi by the router/modem, and use that instead of To access the Pi from outside your network, you will need to either 1) forward port 443 in your router and/or modem for the Pi’s IP address, 2) Connect to a VPN server hosted on your local network, then connect to the Pi’s assigned IP address, or 3) run a reverse proxy, such as frp.

First of all, thank you for this awesome software, I was struggling to make my own, and it would have way less features.

I found the IP address assigned to the Pi by the router and It works. it is very nice to control the system remotely from my desktop while I can prototype my system “in situ” without the need of peripherals.

I will only try the internet access later when my prototype is done, but thanks for the quick reply!

have a good one!

the desktop is conected via RJ42 cable while the raspberry pi is via wifi, but MyCodo seems to have no problem with that. I’m sorry, i’m very noob with networks.

1 Like

Hey Rick,

If you haven’t figured this out I can give some advice. In order to access your Pi from over the internet you need to get the Public IP of your internet connection. Go to on your computer to get your Public IP. You can then sign up for a free dyndns service like noip or dynu. That will allow you to create a internet facing name which you link to your Public IP. Reason for this is depending on your internet connection, your Public IP will change every 24 hours, unless you are paying for a static IP, so having that name will prevent you from losing access as it will update each time your IP changes.

The next step will be to open/forward the port you access your Pi on, from your router. Google your router model and port forwarding or have a look in the manual. You need the username and password for your router but based on your msg above you already have this :slight_smile: Best practice is to change the port to something that is uncommon to make it more secure, not sure where to change the port Mycodo runs on but maybe Kyke can chip in, haven’t looked but I’m sure it’s possible.

So to sum up, forward the port from your Router to your Pi so that it’s open from the internet.
If possible change it to something secure.
Then lastly get your Public IP and setup a Dyndns account. Just google free dyndns.
Once you have created a dyndns account and linked it to your IP, you need to set this account up on your Router. Most routers will have an option to setup a dyndns account. it will ask you for the hostname, username & password.
Once that is done you should be able to access it from the internet. Make sure you have a secure password setup for Mycodo as well :slight_smile:


1 Like

I figured over my network, but not over internet yet. I’m waiting for the sensors to arrive, so I can configure that part first.