MCP3008, Error 101, No Module named Adafruit_BBIO

Hi together,

I have a problem with an MCP3008.

I configured an Input for the MCP3008, when I activate the Input I get this failuer code in the Deamon log.


I tried to install the module Adafruit_BBIO on the rPi manually but it doesn´t work.
I hope someone can helb me.

Did you install it to the virtual environment Mycodo uses at ~/Mycodo/env?

Hey Kyle,

thank you very much for your answer, I appreciate it very much.
A friend helpd me with a better understanding and yes we installed it there.
But know I have an other Error.

I just added a new MCP3008 Input using the mcp3008 library. Upgrade to master if you want to test and see if it works.

Hi Kyle,

I installed your new version with the Upgrade master, but I have more ore less the same error.

I added a new Input using the CircuitPython library. Make sure you delete any of the previous test Inputs you may have added, before upgrading to master or upgrading to the next release, or you will break your system. I deleted the previous test Input since it wasn’t going to work.

Hi Kyle,

I deleted the test Inputs from the MCP and update to the Master but I have still the same Error.

You’re not using the new Input. That’s the first input. Now that I look at your last post’s error more closely, that wasn’t using the last new Input either.

Hi Kyle,

sorry for that mistake, I didnt saw the new Input.

Now I took the right one but I stilll have an error.

1 Like

I made a commit for the CircuitPython Input to fix the error, above:

And also restored the deleted MCP3008 input to let you test again:

I have tested every input.

  1. Input MCP3008
    When I will add the Input, the UI sayed that the MCP3008_03 has unmet dependencies.

I installed the missing dependencies but the error was still the same. I installed the MCP3008_03 manually on the UI, it didn´t helped.

I can not add this Input.

  1. Input Adafruit_CircuitPython_MCP3XXX
    When I acivate this Input the Deamon log is showing the following error massage.

  2. Input Adafruit_MCP3008
    When I acivate this Input the Deamon log is showing the following error massage.

This library doesn’t seem to work. I’ve removed it and am exclusively looking at the CircuitPython library as a replacement. Delete all of these inputs before upgrading to master to prevent issues with your system.

This should be fixed now:

Adafruit_MCP3008 is the library (deprecated) you had the initial error. So don’t use it- I am in no way trying to fix it.

When I will add the Input Adafruit_CircuitPython I get the message in the right upper corner.


I’m not getting that error. It’s a simple Input, just like all the others. As long as you deleted all previous inputs and upgraded to master like I mentioned, you shouldn’t have any issues.

I Installed again to the Master. It looks that the problem is solved.

Thank you for your Support

Which problem is solved?

I can activate the Adafruit_CircuitPython Input with out an error in the deamon log.