Mycodo: all sensors readings 0

Hello everyone,
my first topic on this forum, since I couldn’t find anything related in the log.

I’m currently running MyCodo on three different indoor chambers on Rpi 4. It works fine on two of them, but there’s a nice problem on the third one.

All sensors (Temp/hum, atlas EC, pH and CO2) give ‘0’ in the live measurement section. They appear with the right address on the terminal (i2cdetect command) and no error appears on the deamon.

Sensors are working fine if I move them to the other chambers, so the problem appears not to be in the sensors, nor in MyCodo (I’ve also tried to reinstall from scratch a couple of times). But somehow somewhere something is not working.

Any ideas?


It’s really difficult to guess what could be wrong with your system without a wiring diagram to help troubleshoot. Have you double checked your ground wires? Have you tried connecting only one sensor at a time to that Pi having trouble to see if it works? Are you sure that none of your sensors are using the same I2C address? Are you sure that Pi isn’t damaged? Could be many variables causing this problem.

Thanks for the answer.
Here is the wiring diagram:

Yes I checked the wiring several times, and also tried to bypass the whole structure and connect a single sensor (correctly working on another system) directly to the RPi. It was present on the bus at the correct address, but the reading was still 0.

If the issue is the RPi any ideas how I could detect them?

What is the Period that you have set in the Input settings for these sensors? How many seconds between measurements? Are you sure you are waiting long enough to see the live measurements page getting populated with the measurements? Have you tried setting up any dashboard gauges for these sensors? Do those show any data?
Have you tried enabling the Log Level: Debug check box in the settings of these sensors and then clicking on the “acquire measurements now” button? What happens? Are there any errors in the logs with the debug check enabled?
Which libraries are you driving the sensors with? Some sensors have multiple libraries you can choose from, have you tried any of the other libraries if available?
Have you tried using a different I2C bus on that Pi 4?
It sounds like that Pi could be damaged?