Picture permissions - can't rsync

Yesterday I configured the PiCam v2 and set the folder path the ~/Pictures. I was able to remotely rsync the files from the Pi then setup a Trigger to only capture during certain hours but can no longer rsync the new files even though the new files are in the folder. Permissions are rw-r. I failed to see what the old permissions were as I already deleted them.

Are they writable by the user “mycodo”?

Yes. Can you setup a password for mycodo user to do ssh/rsync? Long term I may get a USB SSD to rsync off that to reduce wear on the microSD.

Ah ha! Built in rsync! Setting it up to test now. Error: Unknown controller Function_Custom when trying to backup camera directory (~/Pictures).

I’ve set the camera directory to default. Run ssh keygen, imported the key on the destination host so I can login without a password but still get the same error as above.

Got it! @KyleGabriel the problem is the new Raspberry Pi OS install. Doesn’t default to using ‘pi’ as the username so the new default user isn’t in the ‘mycodo’ group. I don’t know why it didn’t hit me until today. The fact I had to run sudo rsync never tipped me off!

1 Like