Problem reading anyleaf ph and orp sensors from the i2c bus


First of I would like to thank Kyle for Mycodo, it´s an amazing piece of software that I have enjoyed for some time now.
Now to my issue, I´m running an Rpi 3B. It had a very old version of mycodo (and rasbian) installed, maybe 2 years out of date.
On this installation I had one SCD30 sensor, one anyleaf PH sensor and one anyleaf ORP sensor connected, everything was working fine until I no longer had any use for it and I put it on a shelf for a year.
Now I went to dust it off again and everything was still working fine, but since it was so out of date I went to upgrade mycodo. This broke everything, nothing worked. Ok. I´ll just do a fresh install.

I installed raspbian 32bit version and mycodo. So far so good.
I can detect all three sensors using i2cdetect and they also show up in the system information page, I get data from the SCD30 sensor but nothing from the anyleaf sensors.

If I run the example python script from anyleaf homepage, I can read and I get data from them so wiring and hardware seems to be working fine.
But I have no clue what my next step should be to get them working in mycodo.
Any help is appreciated.

1 Like

Hi Tobbe,
The very first thing to do if you experience an issue with any Mycodo Input, Output, or Function, is to enable “Log Level: Debug” in its settings, save/activate it, and look in the Daemon Log for any errors or log lines that indicate what the issue is.

Hi Kyle

Sorry for taking so long to get back to this, Xmas and new years got in the way.

After activating the debug and reading the log, the input could not activate. There were some excellent links in there though and the problem was with numpy.
sudo apt-get install libatlas-base-dev

Then rebooted the system and the issue was resolved.
Thanks for your help, much appreciated