Problem to install dependencies for BME680 Adafruit_circuitPython

I can not install from Mycodo software(Adafruit_circuitPython_BME680), look something about the version is not in the time. How i can update this?
this is the log:
2022-03-09 21:16:57] Dependency installation beginning. Installing: adafruit_bme680

[2022-03-09 21:16:57]
[2022-03-09 21:16:57] #### Installing/updating adafruit-circuitpython-bme680==2.5.4 (pip-pypi)
[2022-03-09 21:17:02] Looking in indexes: Simple index, piwheels - Simple index
[2022-03-09 21:17:02] ERROR: Could not find a version that satisfies the requirement adafruit-circuitpython-bme680==2.5.4 (from versions: 3.0.3, 3.0.4, 3.0.5, 3.0.6, 3.0.7, 3.1.0, 3.1.1, 3.1.2, 3.1.3, 3.2.0, 3.2.1, 3.2.2, 3.2.3, 3.2.4, 3.3.0, 3.3.1, 3.3.2, 3.3.3, 3.3.4, 3.4.0, 3.4.1, 3.4.2)
[2022-03-09 21:17:02] ERROR: No matching distribution found for adafruit-circuitpython-bme680==2.5.4

[2022-03-09 21:17:03] End install of adafruit_bme680

[2022-03-09 21:17:03]
[2022-03-09 21:17:03] #### Setting permissions

[2022-03-09 21:17:08] #### Dependencies installed. Restarting frontend and backend…

[2022-03-09 21:17:13] #### Dependency install complete


1 Like

Hi Sergio,

This issue was fixed in 7aef1be, and is included in the yet-to-be released 8.13.0 version of Mycodo. If you would like to make the fix, merely change the version number in the file, below, reboot, and try to install the dependency again.

1 Like

Thanks so much Kylegabriel and slashie

How i can access to the file? i try in to click in dependencies button but i can not have access to the file.
How i can do that?
i tried to go inthe sdcard by the computer but i dont find any folder from mycodo. :confused:
I will appreciate a bit of help. thanks

The easiest way is to SSH into your Pi and make the change using a command line text editor. This is how I generally do it.

  1. If using windows, download an SSH client such as PuTTY.
  2. Connect to pi@, changing to the IP address of your Pi. The default password is “raspberry”.
  3. If SSH is not enabled on your Pi, you will need to remove the SD card and insert it into a computer and add a blank file named “ssh” (without an extension) to the boot partition. Insert the SD card back into the Pi and after booting, the SSH server should be running.
  4. Once logged in, type “nano ~/Mycodo/mycodo/inputs/” and it will open the file in the text editor.
  5. Use the arrow keys to move to the end of the version number in the dependency section, delete the version, and replace it with “3.4.1”, then press Ctrl+X, then “y” to save changes, then press enter to confirm the filename.
  6. Reboot with the command “sudo shutdown now -r”

Done! I learned a lot. thanks again

Hello again, its not showing meters. maybe my sensor is not compatible. i have this one BME680 - STEMMA QT T, H, P & G Sensor Dev Tool - Adafruit | Mouser . I was thinking is similar to adafruit version. How can i do compatible? Is possible?

(post deleted by author)

i connected the bme680 4 wires to SDAgpio2, SCLgpio3, 5V, and Ground.
the led is working but i can not seemeasures in the software.
Maybe i miss something?

Do you have I2C enabled? This can be changed from the Mycodo UI from Configure → Raspberry Pi → Enable I2C or from the command line tool using “sudo raspi-config”, then selecting Interface Options → I2C → Enable. A reboot is necessary for the change to take effect.

Okay, i didnt do before. i was just investigating in theconsole andi tiped i2cdetect, and it shows some options and just i writte down i2cdetect -l (dont ask me why) to see what happen. just look like the console asume something but i dontk now what was :roll_eyes:
I should go back? will be a problem? i dontknow the function of this command.
Thanks KyleGabriel

is not working after enable i2c mode. Maybe what i did in the console was the problem?

sorry for my poor explication. Just i tiped i2cdetect -l trying to see if is any response from the console but i tiped -l by mistake. I dont know if this that i did was the responsable of the sensor is not sending information.
Thanks for patience

i2cdetect only reads, so you can’t cause any damage with it. Does the device appear when you run i2cdetect -y 1?

the problem was i didnt change the i2c address 0x76 to 0x77, now is perfectly reading.
I have other problem trying to set a generic ph ec with the ads1115. I will open a new post for better organization

1 Like