Raspberry Pi 5 and GPIOs

Anybody using RP5 and GPIOs to control their device? It appears that pigpiod is not working on the new pi. Any alternatives ?

1 Like

I’m also having issues with the RPi5 and GPIO.

It seems the RPI.GPIO library no longer works with RPi5.

I’m trying to make progress using a package rpi-lgpio. This is supposed to provide a compatibility layer. It’s not exactly straightforward for a beginner. I’ve created a Python virtual environment using the line

python -m venv --system-site-packages env

activated that with

source env/bin/activate

in the root directory and installed the lgpio package with

sudo apt remove python3-rpi.gpio pip3 install rpi-lgpio

This hasn’t worked so far, I still get the ‘output not set up’ error. Using pinctrl I’ve set my example, GPIO17 to output from none.

I’m just clutching at straws now so any comment would be appreciated.

It looks like the new RPI5 IO architecture is a significant departure from the prev versions. I won’t hold my breath on this one … it’ll take a while for the relevant libraries to get updated.

I can go back to the RPI 4 , but where’s the fun in that :slightly_smiling_face:

I2C is working , so I switched to an I/O expander ( PCF8575) instead. That complicates things a bit as I need to adapt the generic stepper motor custom output , but ok … there’s a path fwd.

There’s always a path forward. I think I might look into writing a Python script as an output, using the gpiozero library. Really new to this but seems reasonable. If not might just get a zero 2, would be the path of least resistance.