Recently updated and now webportal is very slow

I have been using version 8.14.2 for about a year+ with good results, using Influx 1.

I recently installed the newest version (8.15.3) on a fresh SD card and exported my settings from the previous version to the new version. Only the setting portion, not the databases. Set the new version to use Influx 2.

After loading the previous installs setting into the fresh version of Mycodo the web portal is extremely slow. Taking on average 30+ seconds to load the live data screen after entering the local IP and any screen after.

Also, all the AS probes I have are no longer reading.

Any suggestions?

1 Like

What is the hardware and software environment?

I am using the Pi 4B, 8GB model running the current version of Raspian 64bit headless connected via ethernet

Which version? I’ve heard many people state latest and it not actually be the latest.

Version is not listed in the Raspberry Imager but it says the release date it 12/11/23


Also, after install I ran update/upgrade prior to Mycodo install.

“Bookworm” would be the Debian release, which is the latest stable, also known as version 12.

A Pi 4 running Bookworm and InfluxDB 2.x is a stable combination. I suspect your SD card is the limiting factor. I would recommend using an SSD for best performance. 120 GB SSDs can be found for <$20 these days. Grab an SATA to USB cable and SSD and you will have significantly higher performance and reliability over an SD card.

This setup has really been to learn about Mycodo over the last year or two.

For a production system would you recommend a miniPC (Intel) with SSD and a Debian install?

There are a lot of factors that would go into that decision, but I think a Pi 4 or 5 can make a very stable production system, as long as you understand issues that can arise (same for any hardware you use). Using an SSD over an SD is really the best upgrade you can do for stability and performance. Adding a uninterruptible power supply (UPS) to prevent data corruption that can occur from a sudden power loss is the next I’d recommend. A real time clock (RTC) module is also valuable, since if after a power failure an internet connection isn’t available to acquire the time, your clock may set itself to the past and read invalid measurements from the database. The Pi 5 now has a built in RTC.

1 Like

I will add as SSD to the Pi system today. The SSD is nice too as it makes maintenance and backup much easier. :sweat_smile: Thank you very much for the information sir. :beers:

We do actually already have a UPS system in place specifically for the Pi and its associated router as well as a local NTP server that the Pi is set to follow. All of the Tasmota local devices (50+) do best with a dedicated timekeeping service on the network.

1 Like

I have installed Raspian Bookworm on a 100GB SSD in a USB3 enclosure. It is running on a USB3 port. The web portal lag has been eliminated :beers:

The probes and MQTT inputs are still not registering.

Mycodo is able to send MQTT outputs, Mycodo is able to control WiFi devices on the network via MQTT.

The Inputs seem to be set up correctly. I even deleted and re-added the Temp probe to see if generating a new Input ID helped.

When I plug the original SD card back in running 8.14.2 the inputs work fine.

Any suggestions?

Are you running them with Debug Log Level enabled and checking the daemon log for anything out of the ordinary? Did you enable I2C on your new install?

1 Like

I2C was disabled, problem solved :beers:

1 Like