Restored a Mycodo settings file and now my dashboard is all empty boxes

I switched my install to a new SD card and used the settings backup function to transfer my setttings over, but now my dashboard is broken. All I get is these empty square boxes when I try to look at it

1 Like


1 Like

Open your browser’s inspector and what javascript error(s) appears in the console?

You can always just create a new dashboard.

I tried creating a new dashboard, same problem :frowning:

404 is the error code for not found. Perhaps it’s because you’re not using the IP address.

we tried the IP and same thing, I think maybe some dependency is missing because restored the backup and never got prompted to install them?

The restore should have installed dependencies. But even if that didn’t, adding a new widget would check if the dependency exists and prompt you to install the dependency again if it’s not fulfilled.

oh ok, there goes my only theory. we spotted another error when clicking on a list item not sure if its helpful

Have you rebooted since restoring? Simple thing you should always try first before anything.

yeah I have been rebooting with every change, doing it again right now

No need to do it more than once. Try upgrading to master.

hooray that seems to have worked thanks so much! Nothing impresses people like a big wad of sweet gauges!

1 Like